Seting Modem Speedy

download Seting Modem Speedy

of 13

  • date post

    27-Oct-2014
  • Category

    Documents

  • view

    38
  • download

    5

Embed Size (px)

Transcript of Seting Modem Speedy

Berikut adalah seting Warnet dengan menggunakan modem D-Link untuk SpeedyHaruno Sajati Jurusan Teknik Elektro STT Adisutjipto Yogyakarta jati@stta.ac.id

Bagian I Pengaturan Modem Skema adalah sebagai berikut: User (klien) Mikrotik Modem D-Link Line Telpon Internet

Komputer mikrotik (gateway) memiliki 2 kartu jaringan (satu kearah local (192.168.0.254) dan satunya kearah modem (192.168.1.2)) 1. Buka Browser dan akses alamat modem d-link anda (dalam hal ini saya menggunakan default address (192.168.1.1)) 2. Login pada layer login seperti tampak pada gambar (default untuk D-Link adalah username : admin password : admin)

Setelah anda sukses untuk login, muncul tampilan dibawah ini :

3. Pilih tombol run wizard : dan lakukan 3 langkah pengesetan seperti pada gambar:

4. Seting zona waktu :

5. Tekan Tombol Next 6. Pilih mode bridge pada tampilan dibawah ini.

7. Tekan tombol Next dan konfigurasikan VPI dan VCI (saya kurang tahu mengenai keduanya) Tapi menurut telkom 147 yang saya Tanya VPI = 8 dan VCI = 81 (Jika ada yang mengerti mengenai angka ini mohon penjelasan)

8. Selesai!!!

Bagian II Pengaturan Router Mikrotik 1. Seting Mikrotik Anda. Untuk penjelasan instalasi mikrotik, tidak saya jelaskan. Jika ada link lengkap mengenai tutorial instalasi minta dunk! Yang saya lakukan hanya menginstal mikrotik dengan paket : System, web proxy, routing, User Management dan ppp 2. Setelah instalasi mikrotik selesai login pada console mikrotik. Username defaultnya adalah admin dan kosongkani pada passwordnya 3. Setelah anda login cek keberadaan kedua kartu jaringan anda

[admin@mikrotik] > interface print Flags: X - disabled, D - dynamic, R - running # NAME TYPE RX-RATE 0 ether1 ether 0 1 ether2 ether 0

TX-RATE MTU 0 1500 0 1500

4. Ubah dulu nama dari masing-masing kartu jaringan tersebut: [admin@mikrotik] > interface ethernet set ether1 name=internet [admin@mikrotik] > interface ethernet set ether2 name=local 5. Cek kembali kondisi interface anda: [admin@mikrotik] > interface print Flags: X - disabled, D - dynamic, R - running # NAME TYPE RX-RATE 0 internet ether 0 1 lokal ether 0

TX-RATE MTU 0 1500 0 1500

6. Hati-hati jangan sampai terbalik karena akan membingungkan proses selanjutnya. Untuk amannya, berikan alamat (IP) pada sebuah interface kemudian testingkan. Saya ambil contoh untuk interface yang menuju ke modem. [admin@mikrotik] > /ip address add address=192.168.1.2/24 interface=internet [admin@mikrotik] > ping 192.168.1.1 192.168.1.1 64 byte ping: ttl=64 time=2 ms 192.168.1.1 64 byte ping: ttl=64 time interface print Flags: X - disabled, D - dynamic, R - running # NAME TYPE RX-RATE 0 internet ether 0 1 pppoe-user-speedy pppoe-out 0 2 lokal ether 0

TX-RATE 0 0 0

MTU 1500 1492 1500

13. Setelah selesai anda dapat melihat IP yang diberikan kepada anda. [admin@mikrotik] > /ip address print Flags: X - disabled, I - invalid, D - dynamic # ADDRESS NETWORK 0 192.168.1.2/24 192.168.1.0 1 D 125.163.255.147/32 125.163.255.1 2 192.168.0.254/24 192.168.0.0 14. Lakukan tes ke alamat 125.163.255.1 [admin@mikrotik] > ping 125.163.255.1 125.163.255.1 64 byte ping: ttl=64 time=32 ms 125.163.255.1 64 byte ping: ttl=64 time=32 ms 125.163.255.1 64 byte ping: ttl=64 time=32 ms 125.163.255.1 64 byte ping: ttl=64 time=32 ms 4 packets transmitted, 4 packets received, 0% packet loss

BROADCAST 192.168.1.255 0.0.0.0 192.168.0.255

INTERFACE internet pppoe-user-speedy lokal

15. Langkah berikutnya adalah menentukan gateway dan Routingnya dilanjutkan pemberian DNS [admin@mikrotik] > /ip route add gateway=125.163.255.1 16. Tes kembali routing anda [admin@mikrotik] > /ip route print Flags: X-disabled, A-active, D-dynamic, C-connect, S-static, r-rip, b-bgp, o-ospf # DST-ADDRESS 0 ADC 125.163.255.1/32 1 ADC 192.168.1.0/24 2 ADC 192.168.0.0/24 4 A S 0.0.0.0/0 PREF-SRC G GATEWAY 125.163.255.147 192.168.1.2 192.168.0.254 r 125.163.255.1 DIS INTERFACE pppoe-user-speedy internet modem pppoe-user-speedy

17. Pemberian DNS [admin@mikrotik] > /ip dns set primary-dns=203.130.206.250 [admin@mikrotik] > /ip dns set secondary-dns=202.134.2.5 [admin@mikrotik] > /ip dns allow-remote-request=yes 18. Setelah langkah tersebut coba anda tes koneksi ke alamat DNS anda [admin@mikrotik] > ping 203.130.206.250 203.130.206.250 64 byte ping: ttl=64 time=60 ms 203.130.206.250 64 byte ping: ttl=64 time=54 ms 203.130.206.250 64 byte ping: ttl=64 time=54 ms 203.130.206.250 64 byte ping: ttl=64 time=52 ms 4 packets transmitted, 4 packets received, 0% packet loss [admin@mikrotik] > ping 202.134.2.5 202.134.2.5 64 byte ping: ttl=64 time=60 ms 202.134.2.5 64 byte ping: ttl=64 time=54 ms 202.134.2.5 64 byte ping: ttl=64 time=54 ms 202.134.2.5 64 byte ping: ttl=64 time=52 ms 4 packets transmitted, 4 packets received, 0% packet loss 19. Kemudian coba ping ke salah satu alamat situs missal yahoo.com [admin@mikrotik] > ping yahoo.com 216.109.112.135 64 byte ping: ttl=64 time=360 ms 216.109.112.135 64 byte ping: ttl=64 time=354 ms 216.109.112.135 64 byte ping: ttl=64 time=354 ms 216.109.112.135 64 byte ping: ttl=64 time=352 ms 4 packets transmitted, 4 packets received, 0% packet loss

20. Sampai di langkah ini berarti mesin mikrotik anda telah online internet 21. Saatnya membagikan akses internet tersebut ke klien anda: [admin@mikrotik] > /ip firewall nat add chain=srcnat action=masquerade Fitur Opsional: Web-Proxy admin@mikrotik] > /ip web-proxy set enabled=yes port=8080 hostname=proxy.koe transparentproxy=yes admin@mikrotik] > /ip firewall nat add in-interface=lokal dst-port=80 protocol=tcp action=redirect to-ports=8080 chain=dstnat dst-address=!192.168.1.1/24 Sampai di sini pengaturan mikrotik udah selesai. Akan tetapi lebih baik jika ditambah parameter firewall untuk keamanan port sebagai berikut: / ip firewall address-list add list=ournetwork address=192.168.1.1/24 comment=Datautama Network disabled=no add list=ournetwork address=192.168.0.0/24 comment=LAN Network disabled=no Selanjutnya copy-paste skrip berikut pada console mikrotik / ip firewall filter add chain=forward connection-state=established action=accept comment=allow established connections disabled=no add chain=forward connection-state=related action=accept comment=allow related connections disabled=no add chain=virus protocol=udp dst-port=135-139 action=drop comment=Drop Messenger Worm disabled=no add chain=forward connection-state=invalid action=drop comment=drop invalid connections disabled=no add chain=virus protocol=tcp dst-port=135-139 action=drop comment=Drop Blaster Worm disabled=no add chain=virus protocol=tcp dst-port=1433-1434 action=drop comment=Worm disabled=no add chain=virus protocol=tcp dst-port=445 action=drop comment=Drop Blaster Worm disabled=no add chain=virus protocol=udp dst-port=445 action=drop comment=Drop Blaster Worm disabled=no add chain=virus protocol=tcp dst-port=593 action=drop comment=________ disabled=no add chain=virus protocol=tcp dst-port=1024-1030 action=drop comment=________ disabled=no add chain=virus protocol=tcp dst-port=1080 action=drop comment=Drop MyDoom disabled=no add chain=virus protocol=tcp dst-port=1214 action=drop comment=________ disabled=no add chain=virus protocol=tcp dst-port=1363 action=drop comment=ndm requester disabled=no

add chain=virus protocol=tcp dst-port=1364 action=drop comment=ndm server disabled=no add chain=virus protocol=tcp dst-port=1368 action=drop comment=screen cast disabled=no add chain=virus protocol=tcp dst-port=1373 action=drop comment=hromgrafx disabled=no add chain=virus protocol=tcp dst-port=1377 action=drop comment=cichlid disabled=no add chain=virus protocol=tcp dst-port=2745 action=drop comment=Bagle Virus disabled=no add chain=virus protocol=tcp dst-port=2283 action=drop comment=Drop Dumaru.Y disabled=no add chain=virus protocol=tcp dst-port=2535 action=drop comment=Drop Beagle disabled=no add chain=virus protocol=tcp dst-port=2745 action=drop comment=Drop Beagle.C-K disabled=no add chain=virus protocol=tcp dst-port=3127 action=drop comment=Drop MyDoom disabled=no add chain=virus protocol=tcp dst-port=3410 action=drop comment=Drop Backdoor OptixPro disabled=no add chain=virus protocol=tcp dst-port=4444 action=drop comment=Worm disabled=no add chain=virus protocol=udp dst-port=4444 action=drop comment=Worm disabled=no add chain=virus protocol=tcp dst-port=5554 action=drop comment=Drop Sasser disabled=no add chain=virus protocol=tcp dst-port=8866 action=drop comment=Drop Beagle.B disabled=no add chain=virus protocol=tcp dst-port=9898 action=drop comment=Drop Dabber.A-B disabled=no add chain=virus protocol=tcp dst-port=10000 action=drop comment=Drop Dumaru.Y, sebaiknya di didisable karena juga sering digunakan utk vpn atau webmin disabled=yes add chain=virus protocol=tcp dst-port=10080 action=drop comment=Drop MyDoom.B disabled=no add chain=virus protocol=tcp dst-port=12345 action=drop comment=Drop NetBus disabled=no add chain=virus protocol=tcp dst-port=17300 action=drop comment=Drop Kuang2 disabled=no add chain=virus protocol=tcp dst-port=27374 action=drop comment=Drop SubSeven disabled=no add chain=virus protocol=tcp dst-port=65506 action=drop comment=Drop PhatBot, Agobot, Gaobot disabled=no add chain=forward action=jump jump-target=virus comment=jump to the virus chain disabled=no add chain=input connection-state=established action=accept comment=Accept established connections disabled=no add chain=input connection-state=related action=accept comment=Accept related connections disabled=no add chain=input connection-state=invalid action=drop comment=Drop invalid connections disabled=no add chain=input protocol=udp action=accept comment=UDP disabled=no add chain=input protocol=icmp limit=50/5s,2 action=accept comment=Allow limited pings disabled=no add chain=input protocol=icmp action=drop comment=Drop excess